ASK A QUESTION

Ask A Question

Car Engine Maintenance and Advice questions

Engine Questions

View the latest Engine questions below.

Previous Questions & Answers

SPECIAL OFFER
Mazda 2 1.3 Tamura 5dr

Mazda 2 1.3 Tamura 5dr

March 2014 NX14UCO, Petrol Black Manual 57 MPG

£30 For 12 Months Road Tax, 15" Alloy Wheels, Air Conditioning, Full Service History, One Previous Owner View more...

29k miles

ONLY
£6,695
WAS
£6,999
SPECIAL OFFER
Ford Fiesta 1.25 82 Zetec 5dr

Ford Fiesta 1.25 82 Zetec 5dr

May 2015 NA15OOX, Petrol Black Manual 54 MPG

Air Conditioning, Alloy Wheels, Front Fog Lights, Full Service History, One Previous Owner View more...

20k miles

ONLY
£7,999
WAS
£8,299
SPECIAL OFFER
Kia Picanto 1.25 2 EcoDynamics 5dr

Kia Picanto 1.25 2 EcoDynamics 5dr

July 2016 RF16RKE, Petrol Black Manual 61 MPG

Daytime Running Lights, Manual Air Conditioning, £20 For 12 Months Road Tax, 14" Alloys, Bluetooth Audio Streaming With Voice Recognition View more...

14k miles

ONLY
£7,995
WAS
£8,495
SPECIAL OFFER
Vauxhall Corsa 1.4 Design 5dr

Vauxhall Corsa 1.4 Design 5dr

May 2015 NU15WWR, Petrol Blue Manual 54 MPG

15" Alloy Wheels, Air Conditioning, Bluetooth, Curtain Airbags, Dab Radio View more...

11k miles

ONLY
£6,999
WAS
£7,499
SPECIAL OFFER
Kia Picanto 1.0 1 Air 3dr

Kia Picanto 1.0 1 Air 3dr

May 2014 NU14TLJ, Petrol Silver Manual 67 MPG

Abs/Ebd, Air Conditioning, Alarm/Immobiliser, Front Fog Lights, Heated Rear Window View more...

06k miles

ONLY
£5,990
WAS
£6,299
SPECIAL OFFER
Citroen C1 1.0i Edition 5dr

Citroen C1 1.0i Edition 5dr

April 2014 NA14MRO, Petrol Red Manual 66 MPG

£0 For 12 Months Road Tax, Air Con, Cd Player, Electric Front Windows, Full Service History View more...

10k miles

ONLY
£4,994
WAS
£5,495
SPECIAL OFFER
Ford Fiesta 1.25 Zetec 5dr [82]

Ford Fiesta 1.25 Zetec 5dr [82]

April 2010 NU10YFY, Petrol Green Manual 52 MPG

15" Alloy Wheels, Air Conditioning, Bluetooth + Usb, Electric Windows, Esp View more...

23k miles

ONLY
£4,994
WAS
£5,294
SPECIAL OFFER
Ford Fiesta 1.25 82 Zetec 5dr

Ford Fiesta 1.25 82 Zetec 5dr

September 2013 YG63RZU, Petrol White Manual 54 MPG

£30 For 12 Months Road Tax, 15" Alloy Wheels, Air Conditioning, Ford Sync, Full Service History View more...

25k miles

ONLY
£7,299
WAS
£7,499
SPECIAL OFFER
Citroen Ds3 1.6 e-HDi Airdream DStyle Plus 3dr

Citroen Ds3 1.6 e-HDi Airdream DStyle Plus 3dr

September 2014 NU64CFX, Diesel Yellow Manual 79 MPG

£0 For 12 Months Road Tax, 17" Alloy Wheels, Auto Headlights And Wipers, Auxiliary Input Socket , Bluetooth View more...

17k miles

ONLY
£8,490
WAS
£8,990
SPECIAL OFFER
Ford Focus 1.6 Zetec 5dr

Ford Focus 1.6 Zetec 5dr

June 2013 FD13UET, Petrol Silver Manual 48 MPG

16" Alloy Wheels, Air Conditioning, Bluetooth + Usb, Dab Radio, Front Fog Lights View more...

37k miles

ONLY
£6,995
WAS
£7,495
ASKED 03 Mar 2017

Question:

hello, i have ford fiesta 2007 1.4 tdci engine has gone on the car so i was have another for fiesta which i was scraping, so i removed complete engine with gear box and swapped over, after job done car was first start no problem, after few days i could hear some noises and when press the clutch the noise will goes away , then i relies it colud be gear box not good then took it to garage to put back oreginal gear box and they did , since then the car wont start !! when put on computer it say (low fuel pressure) it starts by easy starter and runes for ours but it wont start by it self !! any help please what could be wrong with it ??

Show Answer ask a follow up question
ASKED 03 Mar 2017

Question:

I have a 2007 1.8TDCi S-Max, 113,000 miles. It is particularly poor at starting, more so if left for more than a day, but once started is OK for the rest of the day. Engine turns over well but doesn't fire (as though the engine has no fuel). It will then catch but stall but eventually (5th attempt and much cranking) keeps running. Lots of either smoke and/or water vapour when it does start. Might I have an issue with water build up in the fuel supply (can I drain water off the filter?) or is it more likely to be another issue such as injectors/fuel pump. Major service (incl filter) at 101,000; diesel rail (leaking) replaced at 111,000 - could the system not have been bled properly after the rail was replaced? Thanks in antipation.

Show Answer ask a follow up question
SPECIAL OFFER
Ford Fiesta 1.0 EcoBoost Zetec 5dr

Ford Fiesta 1.0 EcoBoost Zetec 5dr

November 2013 NU63ZNO, Petrol White Manual 66 MPG

£0 For 12 Months Road Tax, 15" Alloy Wheels, Adjustable Steering For Reach And Rake, Air Conditioning, Ambient Lighting View more...

14k miles

ONLY
£7,498
WAS
£8,298
SPECIAL OFFER
Ford Fiesta 1.25 82 Zetec 5dr

Ford Fiesta 1.25 82 Zetec 5dr

May 2015 NA15OOX, Petrol Black Manual 54 MPG

Air Conditioning, Alloy Wheels, Front Fog Lights, Full Service History, One Previous Owner View more...

20k miles

ONLY
£7,999
WAS
£8,299
SPECIAL OFFER
Ford Fiesta 1.0 EcoBoost 125 Titanium X 5dr

Ford Fiesta 1.0 EcoBoost 125 Titanium X 5dr

September 2014 NJ64DXK, Petrol Black Manual 66 MPG

Alloy Wheels, Auto Headlights And Wipers, Climate Control Air Conditioning, Ford Sync, Full Service History View more...

46k miles

ONLY
£8,699
WAS
£8,999
ASKED 03 Mar 2017

Question:

Hi I have a Ford Ka 1.3 2008 Reg. Recently the car has developed a small coolant leak, requiring a weekly top up, but there are no visible signs of leakage - external drips etc. I have tried the expensive radweld in case there was a head gasket leak (oil on dipstick is still clean and there is no 'gunk' on the oil filler cap) Some time ago the heater control could not turn down the heater, so the heater valve was changed but he problem persisted. I think that this is a duff electrical control on the interior panel, so I am looking for a replacement part. Do you think the coolant loss is related to this fault, or could you suggest possible causes/remedies for the loss of antifreeze? Thank you

Show Answer ask a follow up question
ASKED 03 Mar 2017

Question:

Hi ive got a smax 2006 2l tdci, recent purchase (60thou miles), the engine has started to overheat intermittently and has water loss but from no area we can see, tried it with thermostat blocked open to see if it stopped it overheating and still does. the temp gauge reads low and then goes from half way to really hot in seconds and engine looses power. there is pressure in the water filler cap when you undo it, water level rises then falls again, we refill and have to squeeze pipes to help water go down. checked the water pump and looks like the timing belt has been renewed aswell a sthe pump. any ideas of what it could be? my dads a mechanic and said its not cylinder head as would do it all the time. fan working fine and all general checks.etc. Where do we go next with it is there a common fault with them that we have missed?

Show Answer ask a follow up question
SPECIAL OFFER
Nissan Juke 1.5 dCi N-Tec 5dr [Start Stop]

Nissan Juke 1.5 dCi N-Tec 5dr [Start Stop]

September 2013 VE63UYX, Diesel Blue Manual 71 MPG

£20 For 12 Months Road Tax, 18" Alloy Wheels, Air Conditioning, Bluetooth, Cruise Control View more...

27k miles

ONLY
£7,999
WAS
£9,799
SPECIAL OFFER
Ford Focus 1.6 Zetec 5dr

Ford Focus 1.6 Zetec 5dr

December 2012 GL62EPF, Petrol Black Manual 48 MPG

16" Alloy Wheels, Air Conditioning, Bluetooth + Usb, Dab Radio, Front Fog Lights View more...

54k miles

ONLY
£6,295
WAS
£6,795
SPECIAL OFFER
Kia Picanto 1.0 65 1 Air 5dr

Kia Picanto 1.0 65 1 Air 5dr

March 2017 NL17RLY, Petrol Silver Manual 63 MPG

Bluetooth Audio Streaming With Voice Recognition, Daytime Running Lights, Electric Front Windows, Manual Air Conditioning, Rds Radio Cd With Mp3 Player View more...

01k miles

ONLY
£7,995
WAS
£8,995
SPECIAL OFFER
SEAT Mii 1.0 75 Mii by Mango 3dr

SEAT Mii 1.0 75 Mii by Mango 3dr

March 2016 NU16FJX, Petrol White Manual 61 MPG

£30 For 12 Months Road Tax, 15" Alloy Wheels, Air Conditioning, Bluetooth, Bluetooth + Usb View more...

02k miles

ONLY
£8,395
WAS
£8,495
SPECIAL OFFER
Ford Fiesta 1.0 EcoBoost 125 Titanium X 5dr

Ford Fiesta 1.0 EcoBoost 125 Titanium X 5dr

September 2014 NJ64DXK, Petrol Black Manual 66 MPG

Alloy Wheels, Auto Headlights And Wipers, Climate Control Air Conditioning, Ford Sync, Full Service History View more...

46k miles

ONLY
£8,699
WAS
£8,999
SPECIAL OFFER
Vauxhall Corsa 1.6T VXR 3dr

Vauxhall Corsa 1.6T VXR 3dr

January 2012 NK61NDV, Petrol Blue Manual 39 MPG

18" Alloy Wheels, Air Conditioning, Aux Connection, Cruise Control, Deflation Detection System View more...

25k miles

ONLY
£7,490
WAS
£7,990
SPECIAL OFFER
SEAT Mii 1.0 75 Mii by Mango 3dr

SEAT Mii 1.0 75 Mii by Mango 3dr

March 2016 NU16FJX, Petrol White Manual 61 MPG

£30 For 12 Months Road Tax, 15" Alloy Wheels, Air Conditioning, Bluetooth, Bluetooth + Usb View more...

02k miles

ONLY
£8,395
WAS
£8,495
ASKED 03 Mar 2017

Question:

hi i have just recently brought a 1.3 ford ka collection 2004. firstly the engine light has come on and has just remained on now always. I first noticed after the car running for 10 or so minutes stationary a temprature warning light appeared on, and smoke was coming from the passengers side near the rad (under the bonnet) however after 5 minutes of driving the light turned off and the smoke had stopped. since this i have topped up the oil as it was just on the minimum. since this the temp light has not come back on, but the car even when run for 5 mins gets extreamly hot. Also when first started its now taking 3 or 4 attempts to start, with alot of revving or it conks out, once running though its fine. id just like a genuine pointer as to possibilites of what this could be, i havnt long had the car so will take it back for the man to fix as he owns a garage, but want to be sure he doesnt palm me offasilbe using the car alot on the motorways with my 4year old son in the back! it needs to be safe. thankyou ever so much for any advice and sorry this is so long.

Show Answer ask a follow up question
SPECIAL OFFER
Citroen C4 Picasso 1.6 HDi Platinum 5dr

Citroen C4 Picasso 1.6 HDi Platinum 5dr

September 2012 SL62LPU, Diesel Silver Manual 54 MPG

17" Roskilde Alloy Wheels, Cruise Control + Speed Limiter, Electric Front/Rear Windows, Full Service History, Hill Start Assist Control View more...

26k miles

ONLY
£7,494
WAS
£8,495
ASKED 03 Mar 2017

Question:

Hello, I have a ford fiesta 1996 1.25 engine, 40 000 miles on it. In the last three weeks it ate 2l of oil. Apart from that, it is often haunting, loosing power, especially on high rpm as well as wobbling. It has nothing to do with cold or hot engine, wet or cold, or whatever weather -- it can happen anytime, randomly, periodically. Although the most problems are on the motorway, when driving fast, on high rpm -- it is wobbling for a while, and that it is fine again. .. I went to service (not ford) twice and they didn't find anything (although between those 3 weeks it lost 2 l of oil). My friend, who used to work for Ford, told me that it is to do with engine calibration and that the software update will solve everything. Meanwhile, when I told that to Ford service, they said it won't fix the problem and offered me to book the car in for diagnostics (which I had twice anyway). Any solutions?

Show Answer ask a follow up question
SPECIAL OFFER
Ford Fiesta 1.0 EcoBoost Zetec 3dr

Ford Fiesta 1.0 EcoBoost Zetec 3dr

March 2015 NU15KHK, Petrol White Manual 58 MPG

£0 For 12 Months Road Tax, 15" Alloy Wheels, Air Conditioning, Ambient Lighting, Bluetooth + Usb View more...

27k miles

ONLY
£8,499
WAS
£8,999
ASKED 03 Mar 2017

Question:

Ford Focus 1.8TDCi registered Jan 2005. I get a squealing noise on start up that may last a minute or so then disappears. This is most noticeable when weather conditions are damp/wet and mainly (though not exclusively) is not there if weather is dry. What is like source / cause? Also have had ignition light stay on on one occasion at start up for duration of short trip (1.5 miles or so). On switching engine off and restarting after this short trip it reverted to working normally and going out when engine started. Likely cause of apparent temporary malfunction?

Show Answer ask a follow up question
ASKED 03 Mar 2017

Question:

hi i have a 1.6 td estate focus 55 plate it has done 85000 miles. The turbo went so i got a freind to get me one and fit it. but the replacemant turbo lasted about 30 miles and blew again. So i bought one and fitted it myself and the turbo lasted about 1 mile and blew the seals again.the turbo The oil is leaking at the air intake side of the turbo. its getting plenty of oil and the return pipe is clear, could it be the intercooler blocked. any ideas please

Show Answer ask a follow up question
SPECIAL OFFER
Ford Fiesta 1.25 82 Zetec 5dr

Ford Fiesta 1.25 82 Zetec 5dr

January 2016 CP65OXF, Petrol Brown Manual 54 MPG

15" Alloy Wheels, Air Conditioning, Cd Player, Central Locking, Front Fog Lights View more...

06k miles

ONLY
£8,394
WAS
£8,998
SPECIAL OFFER
Ford Fiesta 1.0 EcoBoost 125 Titanium X 5dr

Ford Fiesta 1.0 EcoBoost 125 Titanium X 5dr

September 2014 NJ64DXK, Petrol Black Manual 66 MPG

Alloy Wheels, Auto Headlights And Wipers, Climate Control Air Conditioning, Ford Sync, Full Service History View more...

46k miles

ONLY
£8,699
WAS
£8,999
SPECIAL OFFER
Peugeot 3008 1.6 HDi 115 Allure 5dr

Peugeot 3008 1.6 HDi 115 Allure 5dr

March 2013 NL13EKU, Diesel White Manual 58 MPG

18" Alloy Wheels, Adaptive Cruise Control, Auto Dimming Rear View , Auto Headlights And Wipers, Bluetooth View more...

40k miles

ONLY
£8,299
WAS
£8,499
ASKED 03 Mar 2017

Question:

1.25 ford fiesta zetec 16v (2000) Car runs fine upto 30mph, then it starts to rattle, the higher the speed and the longer I rev, the worse the rattling gets until the whole car, pedals, steering and gearstick all wiobble excessivly everytime i accelerate, disengaging the clutch results in the wobbling going, as soon as i put my foot down it comes back. After about 30 minutes of driving, the wobble is so bad it can be felt at slower speeds of 15mph, and the dashboard gauges start to fail, first the temp gauge resets to exactly halfway, then the fuel does the same... 5 minutes later the rev dial gets stuck a 7000 revs, and then finally the speedo gets stuck at 0. If I turn off the car for a few hours the dials all work again, but the engine is still wobbly, it also makes a very feint rattle when revving (like scraping metal sound). Car has done 107k miles, recently had coils replaced, I think the timing belt was done at some point.

Show Answer ask a follow up question
ASKED 03 Mar 2017

Question:

Hiya. I own a 2000 Ford KA Lux and recently there has been a distinct whirring sound coming from the engine, its particulaly loud when the engine is cold and when it first starts up. There are no warning lights coming on on the dashboard and apart from the noise it seems to be driving normally. It also seems to be louder in lower gears or when the car is in low revs. Could it be the fan belt? If so can i change this myself? Thanks for any help you can offer me xx

Show Answer ask a follow up question
SPECIAL OFFER
SEAT Ibiza 1.4 Toca 3dr

SEAT Ibiza 1.4 Toca 3dr

March 2014 NX14HVU, Petrol Red Manual 48 MPG

16" Alloy Wheels, Air Conditioning, Bluetooth, Foglights, Isofix View more...

30k miles

ONLY
£6,495
WAS
£6,995
ASKED 03 Mar 2017

Question:

I have a 1999 (V) Focus 1.8 tddi that has done 87000 miles. I have noticed that there is a significant amount of oil in the intercooler and also an amount of oil in both of the pipes leading from the intercooler. There is a similar amount of oil in both pipes, but slightly more in the one leading to the turbo. The car emits quite a lot of black smoke under full throttle and feels a little sluggish. Other than it drives as usual. Fuel economy is unaffected. What do you think could be causing this?

Show Answer ask a follow up question
ASKED 03 Mar 2017

Question:

i have a ka 51 plate, about 3 months ago i noticed that the water was leaking, however topping it up once a week seemed to keep the problem at bay. then one day on the way to work the inlet manifold gasket finally gave way and we realised with the help of green flag and my local mechanic that this had been the problem all along. so happy it was fixed ive been driving about for two weeks. then this morning when i went to my car i noticed the ground was damp. sure enough its leaking again, not sure where from. but is this a car fault, or was the job not done properly in the first place, loath to pay to have the same problem fixed two weeks later!! if it is their fault will they make me pay a second time???

Show Answer ask a follow up question
SPECIAL OFFER
Ford Fiesta 1.0 EcoBoost Zetec 5dr

Ford Fiesta 1.0 EcoBoost Zetec 5dr

November 2013 NU63ZNO, Petrol White Manual 66 MPG

£0 For 12 Months Road Tax, 15" Alloy Wheels, Adjustable Steering For Reach And Rake, Air Conditioning, Ambient Lighting View more...

14k miles

ONLY
£7,498
WAS
£8,298
SPECIAL OFFER
Citroen C4 Picasso 1.6 HDi Platinum 5dr

Citroen C4 Picasso 1.6 HDi Platinum 5dr

September 2012 SL62LPU, Diesel Silver Manual 54 MPG

17" Roskilde Alloy Wheels, Cruise Control + Speed Limiter, Electric Front/Rear Windows, Full Service History, Hill Start Assist Control View more...

26k miles

ONLY
£7,494
WAS
£8,495
SPECIAL OFFER
Peugeot PARTNER TEPEE 1.6 HDi 115 Outdoor 5dr

Peugeot PARTNER TEPEE 1.6 HDi 115 Outdoor 5dr

March 2013 DK13WXT, Diesel Brown Manual 53 MPG

Led Daytime Running Lights, Electrically Adjustable And Heated Door Mirrors, Full Service History, Manual Air Conditioning With Cooled Glovebox, Sliding Side Doors View more...

42k miles

ONLY
£6,995
WAS
£7,495
ASKED 03 Mar 2017

Question:

Dear Sirs 2001, X reg, Mondeo, 1.8, Verona, Zetex engine Appear to be slowly leaking coolant from the area around the thermostat / temperature sender housing. All hoses checked for splits and securement of hose clips. Leakage seems possibly come from where the black plastic housing which is bolted onto the engine. I have heard that this housing being made of plastic can distort or split . I would be most grateful if you could give me your expert opinion on what may be the possible causes of this leakage. Best regards Norbert

Show Answer ask a follow up question
ASKED 03 Mar 2017

Question:

I own a 2004 mk3 Mondeo 130 TDCI with 47k on the clock and over the past few months I’ve been having problems with the cooling system. When accelerating on the motorway the engine heats up as normal but as soon as I slow down in traffic or come off the motorway onto slower roads the temp gauge goes straight down to about 60 degrees and less sometimes. The thermostat was changed which made no difference and a diagnostic test was carried out by Ford which came up with nothing. As a last resort the thermostat was changed again and it seemed to do the trick, the engine was heating up very quickly from cold and the temp gauge showed 90 degrees at all times. This lasted about 3 weeks but for some reason the car is over cooling again with exactly the same symptoms as before. Can you tell me what you think the problem might be? Thanks in advance for any advice.

Show Answer ask a follow up question
SPECIAL OFFER
Kia Optima 1.7 CRDi 2 Tech 4dr

Kia Optima 1.7 CRDi 2 Tech 4dr

December 2011 LD61ULZ, Diesel Silver Manual 58 MPG

Electric Drivers Seat, Electric Mirrors , Half Leather Upholstery , Heated Front Seats, Rear Parking Sensors View more...

72k miles

ONLY
£7,690
WAS
£7,990
SPECIAL OFFER
Ford Fiesta 1.0 EcoBoost Zetec 5dr

Ford Fiesta 1.0 EcoBoost Zetec 5dr

November 2013 NU63ZNO, Petrol White Manual 66 MPG

£0 For 12 Months Road Tax, 15" Alloy Wheels, Adjustable Steering For Reach And Rake, Air Conditioning, Ambient Lighting View more...

14k miles

ONLY
£7,498
WAS
£8,298
ASKED 03 Mar 2017

Question:

Hi, I have a 52 Ford Focus 1.8TDDI. Ever since I acquired it last year it has had a coolant loss problem which is baffling me. Sometimes it loses 1 Litre of coolant in about 300 miles sometimes less, sometimes more. The problem is the Ford dealer and an Independant garage don't seem to know where it is going. Looking for tell-tale signs, I have found pink/red staining on the top of the starter (the first starter I had to replace as it was heavily corroded and failed). I can never seem to find any wet patches though. The thermostat housing SEEMS OK, but there is plenty of surface corrosion on one of the pipes on the metallic bypass pipework underneath. Are there any weak spots where it is common to lose coolant in this vicinity? There doesn't seem to be any evidence that it is a head gasket issue.

Show Answer ask a follow up question
ASKED 03 Mar 2017

Question:

Hi JenningsFord, I have a ford focus 2004 tdci with 90k on the clock. It makes a nasty noise upon start up whether cold or hot and the noise also continues as the car is idling. When under load, accelerating or cruising their is no noise. It sounds as if something is rubbing and at first I thought cambelt but on inspection it seems to be coming from the fanbelt or some other belt and I can smell something rubbing from down there! The betls all looks fine and the car drives fine, would do you think the problem could be?? Any other belts that could be rubbing or catching something??? Thanks in advance Richard Puddle

Show Answer ask a follow up question
SPECIAL OFFER
Ford B-Max 1.6 TDCi Titanium 5dr

Ford B-Max 1.6 TDCi Titanium 5dr

November 2012 EJ62RPY, Diesel Silver Manual 71 MPG

Led Daytime Running Lights, £20 For 12 Months Road Tax, Air Conditioning + Electric Auto Temperature Control (Eatc), Auto Dimming Rear View Mirror, Ford Sync Bluetooth Connection With Voice Control And Usb Port View more...

31k miles

ONLY
£7,790
WAS
£8,290
ASKED 03 Mar 2017

Question:

Hi, I have recently purchased a 56 plate 2.0 TDCI Focus. It is a year old with 11k on the clock. I have had the following messages come up twice in the last two weeks: "Engine System Fault" followed by "ESP System Fault" - these messages are displayed in the dash / trip computer area and the Engine fault has a corresponding red LED on the left of that area lit while the ESP fault lights an amber LED on the right. The ESP light also comes on in the speedo dial. Both times the AA have been out, told me no fault codes are stored, cleared the messages and the car seems fine. Both times occurred while the car was still relatively cold and under acceleration (one time accelerating hard and the other accelerating normally) - the faults seem to kill the car's power - limp mode? I have the car booked in at a dealer next week but would be interested in any thoughts you had and if you'd seen the problem before. The only mention I can find online about it suggests a faulty weld on the intercooler pipe? It's a real shame as I really like the car but currently have no confidence in it. Many Thanks, Jason.

Show Answer ask a follow up question
SPECIAL OFFER
Kia Picanto 1.0 65 1 Air 5dr

Kia Picanto 1.0 65 1 Air 5dr

March 2017 NL17RLY, Petrol Silver Manual 63 MPG

Bluetooth Audio Streaming With Voice Recognition, Daytime Running Lights, Electric Front Windows, Manual Air Conditioning, Rds Radio Cd With Mp3 Player View more...

01k miles

ONLY
£7,995
WAS
£8,995
SPECIAL OFFER
Citroen C3 Picasso 1.6 HDi 8V Selection 5dr

Citroen C3 Picasso 1.6 HDi 8V Selection 5dr

May 2014 YE14GWW, Diesel Blue Manual 69 MPG

17" Alloy Wheels, Air Conditioning, Bluetooth, Cruise Control, Front Fog Lights View more...

06k miles

ONLY
£7,999
WAS
£8,499
ASKED 03 Mar 2017

Question:

hi could you help me please, i have just purchased a 1996 ford galaxy 2.0 petrol sometimes the car runs fine but others it seems to lack power like it has a flat spot when i accelerate. also the revs are at 1000rpm then dip down to 0 and rise back up whilst parked up, and sometimes when braking at junctions etc, mostly this happens when warm but does not happen all of the time i also noticed a fowl smell like bad eggs in and around the rear of the car please could you shed any light on these problems.thank you.malc

Show Answer ask a follow up question
ASKED 03 Mar 2017

Question:

Hi, i have a ford fiesta courier 1.3 R reg Van, Which keeps cutting out at junctions and has lost power some times it wont even pull off in 1st and then you just feel the engine like kicks in and it pull really good. and some times im driving a long and it starts to kangaro and if this means anything if i go down the motorway the max speed i can get is 72mph no faster and it take about 15 mins on flat ground to get from 60 to 70 with my foot all the way down on the accelerator pedal. more info to try and cure the problems i have had a new idol valve fitted and a new tps sensor oh and a starter motor and before i had the above done i had plenty of power and reached 70 very easily. please help me many thanks ben

Show Answer ask a follow up question
ASKED 03 Mar 2017

Question:

hi i recently bought a 2004 focus c-max 1.6 tdci it has done 45000 miles. ive had to take it back to the garage i bought it from twice already and its going back again tomorrow. they have already changed a turbo pipe and turbo itself they said the turbo was starved of oil. but when i ask what could cause that they just say it could be a number of things. any idea why this would happen ? also since ive had it back and done only 700 miles its used a litre and a half of oil hence why its going back tomorrow again. could using this much oil damage the engine at all ? and any idea what could be wrong? thanks neil

Show Answer ask a follow up question
SPECIAL OFFER
Ford Focus 1.6 Zetec 5dr

Ford Focus 1.6 Zetec 5dr

June 2013 FD13UET, Petrol Silver Manual 48 MPG

16" Alloy Wheels, Air Conditioning, Bluetooth + Usb, Dab Radio, Front Fog Lights View more...

37k miles

ONLY
£6,995
WAS
£7,495
ASKED 03 Mar 2017

Question:

I have recently bought a used Ford KA3. My dealer, driving instructor and motorcare shop assistant all told me it would be OK to use ANY antifreeze/coolant to top up the reservoir - even though it says in the manual not to mix different colours. Any of the containers I looked at in the shops are opaque and you can't see inside to see what the colour is anyway. Having triple-checked, I bought some and now that I have it, have discovered it's blue - and the stuff in my reservoir is an orangey colour. Is it DEFINITELY OK to use this to top it up?

Show Answer ask a follow up question
SPECIAL OFFER
Nissan Juke 1.5 dCi N-Tec 5dr [Start Stop]

Nissan Juke 1.5 dCi N-Tec 5dr [Start Stop]

September 2013 VE63UYX, Diesel Blue Manual 71 MPG

£20 For 12 Months Road Tax, 18" Alloy Wheels, Air Conditioning, Bluetooth, Cruise Control View more...

27k miles

ONLY
£7,999
WAS
£9,799
ASKED 03 Mar 2017

Question:

Hi, i have a ford fiest diesel 1800 on an N plate 96. I have trouble starting it. I have to turn the engine over for about 15 seconds everytime to start, when it starts it will run for about 3 seconds then cut out, then at second start it will run fine with puff of white smoke coming out of the exhaust. I have had the heater plugs replaced but this has made no difference, could you possibly share your thoughts on this problem. Thanks Justin

Show Answer ask a follow up question
SPECIAL OFFER
Ford Fiesta 1.25 82 Zetec 5dr

Ford Fiesta 1.25 82 Zetec 5dr

May 2014 ND14FMK, Petrol Red Manual 54 MPG

£30 For 12 Months Road Tax, 15" Alloy Wheels, City Pack, Dab Radio, Ford Sync View more...

07k miles

ONLY
£8,190
WAS
£8,490
SPECIAL OFFER
Kia Picanto 1.25 2 EcoDynamics 5dr

Kia Picanto 1.25 2 EcoDynamics 5dr

July 2016 RF16RKE, Petrol Black Manual 61 MPG

Daytime Running Lights, Manual Air Conditioning, £20 For 12 Months Road Tax, 14" Alloys, Bluetooth Audio Streaming With Voice Recognition View more...

14k miles

ONLY
£7,995
WAS
£8,495
ASKED 03 Mar 2017

Question:

I am having a terrible time trying to find out how much it should cost to fix my EAC fault on my fiesta. I was told by my ford dealership that it was one of three things and i would have to start at point one...a new choke pedal. I have had to have the Choke pedal replaced which cost £80 but that worked for a day and then the EAC fail started coming on again along with the engine management sign. I took it back to the ford dealer who said that it will cost me a further £720 to have the car fixed, and there are no guarantees this will stop it! surely this is a bit too expensive, something to do with possibly needing a new ecu ? i have typed in EAC fail into google and hundreds of people seem to have a problem with this and i am finding it very frustrating and my partner has now said he wants a second opinion from another garage. The car has only done 15,000 miles in 4 and a half years and has been fully serviced and well looked after. Should it cost this much or am i being taken for a ride? or is this a known fault? nobody seems to be talking any sense

Show Answer ask a follow up question
ASKED 03 Mar 2017

Question:

hi i have a v reg 2.3 for galaxy.for a couple of months now i have been having a problem with it and i am at my wits end as to what is causing it.when i am driving in the lower gears say i have just pulled away in first and sometimes while i am driving in second the car is really slow and sometimes judders then all of a sudden seems to get its power back then shoots off.i have changed the plugs,oil filter,air filter and fuel filter but it still happens.When i changed the plugs it rectified it for about a week.I have also noticed that when i am static at a junction the car revs at 1000rpm but it keeps dipping then comming back up like it is struggling.I have taken the car to a garage,they put the car on the computer but no codes came up.I asked them where we go from here and was told not sure it may be something you will have to put up with.needless to say i will not use them again. i hope you can shed some light on this.thanks

Show Answer ask a follow up question
ASKED 03 Mar 2017

Question:

hi , great site , i own a ford mondeo ( verona ) 1800 cc on a S (1998) plate . i check the car over once a week . this week i had the car running and noticed a noise ( wich seems to be comming from the drivers side of the engine bay ) the car is not using oil or water , the engine code is WM . how can i check if the noise is a water pump , power steering pump or air con pump fault ? the car drives well without any problems , just this noise . many thanks and keep up the great work .

Show Answer ask a follow up question
SPECIAL OFFER
Ford Fiesta 1.25 82 Zetec 5dr

Ford Fiesta 1.25 82 Zetec 5dr

March 2014 NJ14UAY, Petrol Black Manual 54 MPG

15" Alloy Wheels, Day Running Lights, Electric Front Windows, Hill Start Assist, Quickclear Heated Windscreen View more...

17k miles

ONLY
£7,995
WAS
£8,295
ASKED 03 Mar 2017

Question:

when idling and with a/c on you can hear a definate solonoid click then the engine rattles like hell for about 10seconds before going back to normal this rattle also is quite audible when driving and as rev's drop say at a roundabout you can hear it till you touch the throttle again to accelerate. The performance of the car is unaffected and gives great performance both in economy and speed for the 2.0 litre diesel 5 door mondeo 05 130 I am about to have the aux belts changed will this fix or is it bigger prob?? oil /filter has been changed every 7k with the last one a week ago

Show Answer ask a follow up question
SPECIAL OFFER
Peugeot 308 1.6 HDi 92 Active 5dr

Peugeot 308 1.6 HDi 92 Active 5dr

November 2012 LM62LRK, Diesel Silver Manual 67 MPG

Cruise Control + Speed Limiter, £30 For 12 Months Road Tax, 16" Cirrus Alloy Wheels, Air Con, Electric Front Windows View more...

47k miles

ONLY
£5,794
WAS
£5,994
SPECIAL OFFER
Ford Fiesta 1.0 EcoBoost Titanium 5dr

Ford Fiesta 1.0 EcoBoost Titanium 5dr

April 2015 NL15VLX, Petrol Black Manual 66 MPG

£0 For 12 Months Road Tax, 14" Alloys, Air Conditioning, Bluetooth + Usb, Cruise Control View more...

28k miles

ONLY
£8,795
WAS
£8,995
SPECIAL OFFER
Ford Fiesta 1.25 Zetec 5dr [82]

Ford Fiesta 1.25 Zetec 5dr [82]

April 2010 NU10YFY, Petrol Green Manual 52 MPG

15" Alloy Wheels, Air Conditioning, Bluetooth + Usb, Electric Windows, Esp View more...

23k miles

ONLY
£4,994
WAS
£5,294

ASK YOUR

CAR CARE QUESTION